[Eda-dev] Problems with qrouter getting stuck

Øyvind Harboe oyvind.harboe at zylin.com
Mon Oct 16 10:44:11 EDT 2017


On Mon, Oct 16, 2017 at 4:40 PM, Tim Edwards <tim at opencircuitdesign.com>
wrote:

> Hello Øyvind,
>
> >>    Use "qrouter -nog -noc" to avoid all use of graphics;  that makes
>
>>    qrouter text-only.  The "-nog" option is the default used by qflow.
>>>
>>
> Hmmm... still some sort of configuration problem.
>>
>>   ~$ qrouter -nog
>> couldn't load file "/usr/local/share/qrouter/qrouter.so":
>> /usr/local/share/qrouter/qrouter.so: undefined symbol: Tk_DestroyWindow
>>
>
> Try changing line 20 of qrouter.tcl.in in the source from
>
>         load ${QROUTER_LIB_DIR}/qrouter$libext
> to
>         if {${tcl_version} >= 8.6} {
>            load -lazy TCL_DIR/tclmagicSHDLIB_EXT
>         } else {
>            load TCL_DIR/tclmagicSHDLIB_EXT
>         }
>
> I thought that using the Tcl stubs libraries meant that I don't have
> to use "load -lazy", but maybe not.


$ qrouter -nog -noc
couldn't load file "TCL_DIR/tclmagicSHDLIB_EXT":
TCL_DIR/tclmagicSHDLIB_EXT: cannot open shared object file: No such file or
directory



>
>
>                                         ---Tim
>
> +--------------------------------+-------------------------------------+
> | R. Timothy Edwards (Tim)       | email: tim at opencircuitdesign.com    |
> | Open Circuit Design            | web:   http://opencircuitdesign.com |
> | 19412 Cissel Manor Drive       | phone: (301) 528-5030               |
> | Poolesville, MD 20837          | cell:  (408) 828-8212               |
> +--------------------------------+-------------------------------------+
>



-- 
Øyvind Harboe, General Manager, Zylin AS, +47 917 86 146
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.opencircuitdesign.com/pipermail/eda-dev/attachments/20171016/b3cda063/attachment.html>


More information about the Eda-dev mailing list