[Eda-dev] Problems running qflow display

Øyvind Harboe oyvind.harboe at zylin.com
Sun Jul 14 04:32:39 EDT 2019


Ah!

Here's the problem. If magic fails to compile due to e.g. makedbh failing,
then it doesn't return exit code != 0 so that the compile stops.

Can that be fixed?

If so, then I'd be immediately pointed in the right direction when my setup
is broken.





On Sat, Jul 13, 2019 at 11:51 PM Tim Edwards <tim at efabless.com> wrote:

> Hello Øyvind,
>
> This apparently comes down to a difference between "csh" and "tcsh" on
> the system you are using.  Change the first line of "scripts/makedbh"
> from "csh" to "tcsh" and it will generate a correct database.h.
>
> I have not heard of any Linux system having a csh that was not just a
> symbolic link to tcsh. . .  I thought this container was based on a
> stock Ubuntu.  I've never had problems compiling magic with a stock
> Ubuntu before.
>                                         Regards,
>                                         Tim
>
> +--------------------------------+-------------------------------------+
> | R. Timothy Edwards (Tim)       | email: tim at efabless.com             |
> | efabless, inc.                 | web:   http://www.efabless.com      |
> | 2570 N. 1st St., Suite 200     | phone: (240) 489-3255               |
> | San Jose, CA 95131             | cell:  (408) 828-8212               |
> +--------------------------------+-------------------------------------+
>


-- 
Øyvind Harboe, General Manager, Zylin AS, +47 917 86 146
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.opencircuitdesign.com/pipermail/eda-dev/attachments/20190714/891a7adf/attachment-0001.html>


More information about the Eda-dev mailing list