[Eda-dev] Problems running qflow display

Øyvind Harboe oyvind.harboe at zylin.com
Sun Jul 14 05:02:48 EDT 2019


Aha!

The problem is that if I run "make -j4", then it fails. With "make", the
build works. Ubuntu points csh to tsch, so modifying makedbh is not
necessary, unless you install csh, then you have to update makedbh.

Could there be a dependency bug in the Makefile for magic that causes
"makedbh" to be run in parallel and then we get a garbage database.h?

It's been more than once that I've torn my hear out trying to fix
non-idempotent makefiles with build servers.... Makefiles are not bash
files...

So in summary, the fixes that would be really nice to have(but can be
worked around with a carefully tested build procedure, like the
Dockerfile...):

1. "make -j" is broken in magic as it can generate corrupt
database/database.h
2. magic (and maybe netgen it uses makedbh too) does not return != upon
failure. Having accurate exit code would steer the likes of me onto the
right path.




On Sat, Jul 13, 2019 at 11:51 PM Tim Edwards <tim at efabless.com> wrote:

> Hello Øyvind,
>
> This apparently comes down to a difference between "csh" and "tcsh" on
> the system you are using.  Change the first line of "scripts/makedbh"
> from "csh" to "tcsh" and it will generate a correct database.h.
>
> I have not heard of any Linux system having a csh that was not just a
> symbolic link to tcsh. . .  I thought this container was based on a
> stock Ubuntu.  I've never had problems compiling magic with a stock
> Ubuntu before.
>                                         Regards,
>                                         Tim
>
> +--------------------------------+-------------------------------------+
> | R. Timothy Edwards (Tim)       | email: tim at efabless.com             |
> | efabless, inc.                 | web:   http://www.efabless.com      |
> | 2570 N. 1st St., Suite 200     | phone: (240) 489-3255               |
> | San Jose, CA 95131             | cell:  (408) 828-8212               |
> +--------------------------------+-------------------------------------+
>


-- 
Øyvind Harboe, General Manager, Zylin AS, +47 917 86 146
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.opencircuitdesign.com/pipermail/eda-dev/attachments/20190714/cc9058ba/attachment.html>


More information about the Eda-dev mailing list