[Eda-dev] Problem with Qflow tool

Tim Edwards tim at opencircuitdesign.com
Thu Oct 24 15:19:00 EDT 2019


Hello M. Ahmed,

> Hello there,I was working on the example you gave on your  eda website and
> tried converting RTL to GDS,However i ran into the following error,Can you
> help me with this! i followed all the steps you described on website!
> The error detail is attached with this email. Thanks

This looks like a Linux OS-specific thing.  Line 34 of netgen (which is
a shell script) is:

       *) arglist="$arglist${arglist:+ }\"${i//\"/\\\"}\"";;

My guess is that this syntax may be sh-specific and not necessarily
bash-compliant.  The top of that file has:

	#!/bin/bash

which may be relying on the fact that on my system (Fedora Core), bash
and sh are the same.

On the other hand, it appears that qflow succeeded in running DRC,
which requires running magic, which has a similar startup script with
the same line, so I'm not sure why that would run, but netgen would
not.

Can you run netgen from the command line?  Does it produce the same
error?
					Regards,
					Tim

+--------------------------------+-------------------------------------+
| R. Timothy Edwards (Tim)       | email: tim at opencircuitdesign.com    |
| Open Circuit Design            | web:   http://opencircuitdesign.com |
| 19601 Jerusalem Road           | phone: (240) 489-3255               |
| Poolesville, MD 20837          | cell:  (408) 828-8212               |
+--------------------------------+-------------------------------------+



More information about the Eda-dev mailing list