[Xcircuit-dev] trouble with load dependencies, seg fault when creating matching symbol

Colin Nayler colinnayler at yahoo.com
Fri Mar 2 10:36:32 PST 2012



I am a relatively new user of xcrircuit and am using it to create a hierarchical set of schematics.  I'm using version 3.7.32, just compiled.  It's been going pretty good until I tried using the Load Dependencies feature to load schematic pages.  I created a symbol in my project technology library, instantiated it on a top level schematic page, and used the link parameter of the symbol to associate an existing schematic to it.  I then tried from the File menu, Load Dependencies expecting the linked schematic to be loaded on the next schematic page.  Nothing happened.  I double checked the schematic file and object names.  Am I doing something wrong?

Undaunted, I decided to try the procedure described in the Large Project Tutorial for creating a symbol from an existing schematic hoping to get Load Dependencies to work.  First I renamed the existing symbol and saved the technology file to eliminate any naming conflict. Then from the Netlist menu I selected Make Matching Symbol and after a fair amount of delay the dialog box opened up.  I moved the pins around to my liking and pushed the Apply button.  Then I pushed the Okay button and got a segmentation fault.  On a second try I just pushed the Okay button without pushing the Apply button, same result.

Incidentally, I have been successful in creating a hierarchical set of schematics but only when I manually load all the schematic pages and associate the matching symbols manually.  I can also successfully generate a hierarchical netlist from this method.  I'm running on Ubuntu 11.10 64-bit.

Any help with these issues is most appreciated.

Thanks,
Colin


More information about the Xcircuit-dev mailing list