[Xcircuit-dev] trouble with load dependencies, seg fault when creating matching symbol

Tim Edwards tim at opencircuitdesign.com
Sat Mar 3 17:45:36 PST 2012


Hello Colin,

> I am a relatively new user of xcrircuit and am using it to create a
> hierarchical set of schematics.  I'm using version 3.7.32, just
> compiled.  It's been going pretty good until I tried using the Load
> Dependencies feature to load schematic pages.  I created a symbol in
> my project technology library, instantiated it on a top level schematic
> page, and used the link parameter of the symbol to associate an existing
> schematic to it.  I then tried from the File menu, Load Dependencies
> expecting the linked schematic to be loaded on the next schematic page.
> Nothing happened.  I double checked the schematic file and object names.
> Am I doing something wrong?
> 
> Undaunted, I decided to try the procedure described in the Large Project
> Tutorial for creating a symbol from an existing schematic hoping to get
> Load Dependencies to work.  First I renamed the existing symbol and
> saved the technology file to eliminate any naming conflict. Then from
> the Netlist menu I selected Make Matching Symbol and after a fair amount
> of delay the dialog box opened up.  I moved the pins around to my liking
> and pushed the Apply button.  Then I pushed the Okay button and got a
> segmentation fault.  On a second try I just pushed the Okay button without
> pushing the Apply button, same result.
> 
> Incidentally, I have been successful in creating a hierarchical set of
> schematics but only when I manually load all the schematic pages and
> associate the matching symbols manually.  I can also successfully generate
> a hierarchical netlist from this method.  I'm running on Ubuntu 11.10 64-bit.
> 
> Any help with these issues is most appreciated.

I implemented the "load dependencies" feature some time ago and I don't
recall that I have used it recently, so there is a very high likelihood
that I broke it at some point.  I will take a close look at it, since
you have given me a very good and thorough description of the problem.
I don't think you are doing anything wrong, and a segfault is clearly
something I need to address immediately.  I should be able to give some
time to the problem tomorrow.

						Regards,
						Tim

+--------------------------------+-------------------------------------+
| Dr. R. Timothy Edwards (Tim)   | email: tim at opencircuitdesign.com    |
| Open Circuit Design, Inc.      | web:   http://opencircuitdesign.com |
| 22815 Timber Creek Lane        | phone: (301) 528-5030               |
| Clarksburg, MD 20871-4001      | cell:  (240) 401-0616               |
+--------------------------------+-------------------------------------+


More information about the Xcircuit-dev mailing list