[Xcircuit-dev] XCircuit problems on Mac OS X

Tim Edwards tim at opencircuitdesign.com
Fri Mar 16 11:21:14 EDT 2012



-------- Original Message --------
Subject: XCircuit problems on Mac OS X
Date: Tue, 13 Mar 2012 22:49:07 +0100
From: Peter Haagerup <haagerup at gmail.com>
To: tim.edwards at multigig.com

Hi Tim

I have read your troubleshooting information on installing XCircuit on
Mac OS X. I still have a lot of trouble, though. First I tried to
install the package 'xcircuit' using MacPorts. That gave me an old
version of xcircuit (3.4) that seems to work fine, but when saving EPS
and tex-file, LaTeX tells me that the bounding box is missing, but
there is very clearly a boundingbox defined in the eps-file. On my
linux box running xcircuit 3.6, I have never encountered a problem
like that. This problem remains the same no matter how I try to
include the .eps or the .tex file in my LaTex document. I am totally
sure that it is not a LaTeX problem, because I tried the same with my
xcircuit schematics created by my linux box and it works just fine.

So, I am trying to install the newest version of XCircuit (3.7) and
after a lot of trouble, I wrote myself this guide:
1. Install Xcode
2. Install X11
3. Download MacPorts installer and install MacPorts.
4. Open a terminal and type the following to install the required
packages. The installed xcircuit is an old version, so it is removed
again. This step might take quite a long time.
sudo port -v selfupdate
sudo port install xcircuit
sudo port uninstall xcircuit
5. Download the newest stable xcircuit-tgz (ex. xcircuit-3.7.33.tgz
from http://opencircuitdesign.com/xcircuit/
6. In the terminal, go to the directory where the tgz is located and extract it:
tar -xvzf xcircuit-3.7.33.tgz
cd xciruit-3.7.33
7. Now xcircuit has to be configured with the correct X11-libraries
and the Tcl/Tk version that depends on X11 (xcircuit will crash when
using the Aqua version of Tcl/Tk):
./configure --x-include=/usr/X11R6/include/X11
--x-libraries=/usr/X11R6/lib   --with-tcl=/usr/lib/tclConfig.sh
--with-tk=/usr/lib/tkConfig.sh
8. Build xcircuit:
make
9. Install xcircuit:
sudo make install
10. Run xcircuit (you might need to close the terminal and open a new one)
xcircuit

Now it compiles and installs XCircuit using the correct libraries. The
only problem is that when running xcircuit, the main window shows up
for a split second and then fails, writing the following error in the
terminal:

X Error of failed request:  BadValue (integer parameter out of range
for operation)
   Major opcode of failed request:  53 (X_CreatePixmap)
   Value in failed request:  0x0
   Serial number of failed request:  5160
   Current serial number in output stream:  5162

I hope you can help me with either problem or both. I really need
XCircuit on my MacBook. I am running OS X 10.6.8 on a 32-bit Intel
MacBook with X11 (XQuartz 2.3.6 (xorg-server 1.4.2-apple56)). I also
tried the current development version of XCircuit (3.8) with exactly
the same results :-(

Thanks a lot for your time - any help is appreciated :-)

--- Peter Haagerup


-- 
+--------------------------------+-------------------------------------+
| Dr. R. Timothy Edwards (Tim)   | email: tim at opencircuitdesign.com    |
| Open Circuit Design, Inc.      | web:   http://opencircuitdesign.com |
| 22815 Timber Creek Lane        | phone: (301) 528-5030               |
| Clarksburg, MD 20871-4001      | cell:  (240) 401-0616               |
+--------------------------------+-------------------------------------+


More information about the Xcircuit-dev mailing list