[Xcircuit-dev] line edit mode bug

Fmiser fmiser at gmail.com
Sun Mar 18 02:50:56 EDT 2012


> > Philip wrote:
> >
> > Then I press "d" to delete the point shown by the cursor -
> > but the first point in the line is removed while the cursor
> > remains over the last point.

> R. Timothy Edwards wrote:
>
> I have uploaded to the git repository.  This is a major test
> of the whole system setup.

> The tarball may or may not appear tomorrow, depending on
> whether or not I am missing any scripts or tools or files.

The website has a link to xcircuit-3.7.33.tgz on the page http://opencircuitdesign.com/xcircuit/.

But there is no file by that name in http://opencircuitdesign.com/xcircuit/archive/

However, 3.8.10 _does_ exist both in the archive directory and
as a link.  So you got one but not the other...

So I try git.  I have little experience with git, so I'm not
sure I didn't mess something up.

I first tried the command from the website.
  $ git clone git://opencircuitdesign.com/xcircuit-3.7 

That doesn't work if I'm just trying to update, not download the
whole thing again.

After some web research, "cd"ed into xcircuit-3.7 and ran
  $ git pull git://opencircuitdesign.com/xcircuit-3.7 HEAD

That complained about the existence of Makefile.  Next I ran

  $ git clean -xdf
  $ git pull git://opencircuitdesign.com/xcircuit-3.7 HEAD

This seemed to work.  "clean" reported files were deleted.
"pull" reported files changed, or gotten, or something.

I then compiled and installed.  I didn't see any errors or
reports that suggested problems or unusual stuff.

I tried running xcircuit.  Failed with this line:
/usr/local/bin/xcircuit: line 44: /home/tim/cad//lib/xcircuit-3.7/tcl/tkcon.tcl: No such file or directory

I edited /usr/local/bin/xcircuit and change line 8 to:
loclibdir=${XCIRCUIT_LIB_DIR:=/usr/local/lib/xcircuit-3.7}

Now it fails with:
/usr/local/lib/xcircuit-3.7/tkcon.tcl: line 3: /usr/local/bin/wish8.5: No such file or directory

I checked /usr/local/lib/xcircuit-3.7/tkcon.tcl and a
tkcon.tcl from an older build that ran okay.  They are the
same.

So looking at /usr/local/bin/xcircuit again I see that line 10
doesn't match my system.  So I change it from:
XCIRCUIT_WISH=/usr/local/bin/wish8.5
to
XCIRCUIT_WISH=/usr/bin/wish

Now it almost works. I get a tcl console with the error:
couldn't load file "/home/tim/cad//lib/xcircuit-3.7/tcl/xcircuit.so"

I'm getting the distinct impression either there is a config
problem or I'm doing something wrong!

With the help of grep -R, I find and change line 11 and line 19 in
/usr/local/lib/xcircuit-3.7/xcircuit.tcl

And now it runs.  But after all that - the problem is still
there!  I gather the update was made only in the 3.8 branch?

--  Philip


More information about the Xcircuit-dev mailing list