[Xcircuit-dev] line edit mode bug

Tim Edwards tim at opencircuitdesign.com
Sun Mar 18 17:41:39 EDT 2012


Hello Philip,

> The website has a link to xcircuit-3.7.33.tgz on the page http://opencircuitdesign.com/xcircuit/.
> 
> But there is no file by that name in http://opencircuitdesign.com/xcircuit/archive/
> 
> However, 3.8.10 _does_ exist both in the archive directory and
> as a link.  So you got one but not the other...

Bizarre.  I can't think how one of them would work but not the other.  Actually,  I think
it has to do with the time overlap in setting up the new server before taking down the
old one, and making one update in-between, which I copied back from the old server.
I replaced the missing file and with luck it won't happen again.

> So I try git.  I have little experience with git, so I'm not
> sure I didn't mess something up.
> 
> I first tried the command from the website.
>   $ git clone git://opencircuitdesign.com/xcircuit-3.7 
> 
> That doesn't work if I'm just trying to update, not download the
> whole thing again.
> 
> After some web research, "cd"ed into xcircuit-3.7 and ran
>   $ git pull git://opencircuitdesign.com/xcircuit-3.7 HEAD
> 
> That complained about the existence of Makefile.  Next I ran
> 
>   $ git clean -xdf
>   $ git pull git://opencircuitdesign.com/xcircuit-3.7 HEAD
> 
> This seemed to work.  "clean" reported files were deleted.
> "pull" reported files changed, or gotten, or something.

I only give instructions for downloading the whole source into a new directory.
The process of updating with "git" is unnecessarily complicated, tending to
involve memorizing series of commands that need to be run, or writing scripts
to do the job.  I have a co-worker who wrote a bunch of useful scripts to make
"git" work for me remotely synchronizing chip design databases with the server
at work, so I adapted this to opencircuitdesign.com and the various source
code repositories I have there.  It works for me, but it is complicated and
I would have to provide more code and several pages of instructions to make
it useful to anybody else.

> I then compiled and installed.  I didn't see any errors or
> reports that suggested problems or unusual stuff.
> 
> I tried running xcircuit.  Failed with this line:
> /usr/local/bin/xcircuit: line 44: /home/tim/cad//lib/xcircuit-3.7/tcl/tkcon.tcl: No such file or directory

This suggests stuff left over from my compile.  "/home/tim/cad" is
not hard-coded anywhere, but is the direct result of my running
"configure --prefix=/home/tim/cad".

> Now it almost works. I get a tcl console with the error:
> couldn't load file "/home/tim/cad//lib/xcircuit-3.7/tcl/xcircuit.so"
> 
> I'm getting the distinct impression either there is a config
> problem or I'm doing something wrong!

I think so, too, and here's my analysis:  The "git" system is (due to
my lack of vigilance) managing all sorts of files that are made at
compile time and don't belong in the distribution.  Consequently, what
you have after a "git clone" or "git pull" is a mostly-built system
that is built to the specifications of my own desktop computer.  There
are two solutions:  (1) run "make clean" and then do "configure", "make",
"make install".  The "make clean" should clear out everything that has
to do with my desktop environment;  and (2) pick up the tarball (since
I put it back).  Although the "line edit mode bug" specifically relates
to version 3.8, which is where I introduced the error, and version 3.8
always had the correct tarball. . .

The long-term solution is for me to figure out the complete list of
files that I need to add to "gitignore".

						---Tim

+--------------------------------+-------------------------------------+
| Dr. R. Timothy Edwards (Tim)   | email: tim at opencircuitdesign.com    |
| Open Circuit Design, Inc.      | web:   http://opencircuitdesign.com |
| 22815 Timber Creek Lane        | phone: (301) 528-5030               |
| Clarksburg, MD 20871-4001      | cell:  (240) 401-0616               |
+--------------------------------+-------------------------------------+


More information about the Xcircuit-dev mailing list