[Xcircuit-dev] line edit mode bug

Fmiser fmiser at gmail.com
Sun Mar 18 23:38:11 EDT 2012


> > Philip wrote:
> >
> > So I try git.  I have little experience with git, so I'm not
> > sure I didn't mess something up.
 
> > I first tried the command from the website.
> >   $ git clone git://opencircuitdesign.com/xcircuit-3.7 
 
> Tim Edwards wrote:
>
> I only give instructions for downloading the whole source into
> a new directory. The process of updating with "git" is
> unnecessarily complicated, tending to involve memorizing
> series of commands that need to be run, or writing scripts to
> do the job.

Heh.  So I'm discovering!  

> > I then compiled and installed.  I didn't see any errors or
> > reports that suggested problems or unusual stuff.
> > 
> > I tried running xcircuit.  Failed with this line:
> > /usr/local/bin/xcircuit: line
> > 44: /home/tim/cad//lib/xcircuit-3.7/tcl/tkcon.tcl: No such
> > file or directory
> 
> This suggests stuff left over from my compile.
> "/home/tim/cad" is not hard-coded anywhere, but is the direct
> result of my running "configure --prefix=/home/tim/cad".

So I suspected, but why would it not clear or correct when _I_
ran ./configure?

> > Now it almost works. I get a tcl console with the error:
> > couldn't load file
> > "/home/tim/cad//lib/xcircuit-3.7/tcl/xcircuit.so"
> > 
> > I'm getting the distinct impression either there is a config
> > problem or I'm doing something wrong!
> 
> I think so, too, and here's my analysis:  The "git" system is
> (due to my lack of vigilance) managing all sorts of files that
> are made at compile time and don't belong in the
> distribution.  Consequently, what you have after a "git clone"
> or "git pull" is a mostly-built system that is built to the
> specifications of my own desktop computer.

I kinda figured git was "gitting" too much stuff - but wasn't
sure if it was because I was running the wrong commands or
because of setting on the far side.  *sigh*  Git is still mostly
a mystery to me, despite my digging and my notes.

> There are two solutions:  (1) run "make clean" and then do "configure",
> "make", "make install".  The "make clean" should clear out
> everything that has to do with my desktop environment;  and

I know I was running "make clean" at various times.  But I may
not have run it just before running "configure" or just after
"pull".

Again, though, I expected your files would be overwritten my
mine when I ran "configure" even without "make clean".  Or am I
confused here too? *weak smile*

> (2) pick up the tarball (since I put it back).  Although the
> "line edit mode bug" specifically relates to version 3.8,
> which is where I introduced the error, and version 3.8 always
> had the correct tarball. . .

I built 3.8.  And I had to edit /usr/local/bin/xcircuit to
correct the path to wish, but otherwise it built and ran.  I
recall you recently said 3.8 is really not different than 3.7
right now since you are only squashing bugs.  My only real
reason for not using 3.8 is I am generally not especially good
at keeping up.  I tend to stick with a working version for
probably too long, just 'cause I'm too lazy to update. *smiles*

I had this expectation that using git would be an advantage
because I wouldn't have to download the entire source over my
very slow internet connection every time you fix another bug.
But git is not quite living up to my expectations, though maybe
now that I have a usable string of commands it will be okay.

> The long-term solution is for me to figure out the complete
> list of files that I need to add to "gitignore".

And that's the real reason I bothered to post.  I figured you
would want to know about it if there were things amiss,
particularly since you mentioned you had just shifted stuff
around.  

Thanks for your diligence and effort, and for sharing it.

--  Philip


--   Philip


More information about the Xcircuit-dev mailing list