[Xcircuit-dev] xcircuit crashes at startup

Mangal Pandey pandey1857 at gmail.com
Wed May 23 21:40:56 EDT 2012


Thanks Tim for your response. I followed the suggestion from below link and
it is not crashing anymore.
now i will start some design and let see if all the features are working
perfectly.

Thanks again for your help.

-Pandey.

On Wed, May 23, 2012 at 9:06 AM, Tim Edwards <tim at opencircuitdesign.com>wrote:

> Hello Pandey,
>
>
>  I have built xcircuit.3.7.39 on Mac10.6.8. I have installed latest tcl/tk
>> 8.5.11.
>> it is crashing at startup, i tried to run through gdb and found below
>> message.
>> I am sure it would be a known issue and you will be able to help me.
>>
>
>  Starting program: /usr/local/lib/xcircuit-3.7/**xcircexec
>> Reading symbols for shared libraries
>> .++++++++++...................**..............................**
>> ..............................**...................
>> done
>> Reading symbols for shared libraries . done
>> Reading symbols for shared libraries . done
>> Reading symbols for shared libraries . done
>> Reading symbols for shared libraries . done
>> Reading symbols for shared libraries . done
>> Reading symbols for shared libraries . done
>> Reading symbols for shared libraries . done
>> Starting xcircuit under Tcl interpreter
>>
>> Program received signal EXC_BAD_ACCESS, Could not access memory.
>> Reason: KERN_PROTECTION_FAILURE at address: 0x00000030
>> 0x002f01e3 in CmapRecForColormap ()
>>
>
> This has been reported before;  check the discussion on:
>
>   http://blog.gmane.org/gmane.**comp.graphics.xcircuit.devel/**
> month=20100701<http://blog.gmane.org/gmane.comp.graphics.xcircuit.devel/month=20100701>
>
> The issue, as I understand it, is that there is a Mac graphics ("Aqua")
> based version of Tcl/Tk that is found and linked to by xcircuit, and
> that it is incompatible with the X11 graphics calls made by xcircuit.
> To avoid the problem, you will need an X11-based version of Tcl/Tk.
> The email thread above says to get and compile the Tcl/Tk Unix sources
> (presumably downloaded from www.tcl.tk).
>
> If you think that you *do* have the X11 version of Tcl/Tk 8.5.11, then
> I will have to revisit the problem.  Let me know.
>
>                                        Regards,
>                                        Tim
>
> +-----------------------------**---+--------------------------**
> -----------+
> | Dr. R. Timothy Edwards (Tim)   | email: tim at opencircuitdesign.com    |
> | Open Circuit Design, Inc.      | web:   http://opencircuitdesign.com |
> | 22815 Timber Creek Lane        | phone: (301) 528-5030               |
> | Clarksburg, MD 20871-4001      | cell:  (240) 401-0616               |
> +-----------------------------**---+--------------------------**
> -----------+
>


More information about the Xcircuit-dev mailing list